Follow

6.1.3 Hub Upgrade fails due to lack of disk space in / (root) filesystem for EC2 appliances in AWS

Product: Stratusphere FIT/UX

Product Version: 6.1.3

Expires on: 365 days from publish date

Updated: July 10, 2019

 

Problem:

6.1.3 upgrade fails due to lack of disk space in /.  After clicking install in the WebUI, it quickly returns to the login screen and looks like it didn't do anything.  You will see an error like the following in /var/log/lwl-update.log, which you can also check if you ssh/putty into the hub as ec2-user and run:

sudo su -

tail -100 /var/log/lwl-update.log

 

Error Summary

----------------

Disk Requirements

At least 48MB more space needed on the / filesystem.

 

Possible resolution:

Putty into the hub appliance as ec2-user, then run the following to clear space in /:

sudo su -

localedef --delete-from-archive $(localedef --list-archive | grep -v -i ^en | xargs)

cp -f /usr/lib/locale/locale-archive /usr/lib/locale/locale-archive.tmpl

build-locale-archive

 

Then you can run the upgrade again.  The WebUI may force you to download the upgrade image again if doing an online upgrade, so you can run these commands as root on the hub to perform the upgrade manually if already downloaded:

yum clean all

yum check-update

yum upgrade lwl-birt-reports

/opt/lwl/bin/lwl-update.sh -update -force -offline
(If it fails, then run !tail and check the log for the new error.)

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.