Follow

ProfileUnity login error after reboot of persistent machines when using Elevation rules

Product: ProfileUnity-FlexApp

Product Version:  6.8.3 ONLY

Updated: March 3, 2020

Expires on: 365 days from publish date

 

Problem:

mceclip0.png

And missing FlexApps, among other things, on login.

 

Possible workaround:

 

  1. Make sure user logged out of broken machine and repair that machine either by refreshing it from image or by using the copy command below for the lwl_elevation_service.xml.bak and restarting the elevation service afterward.  We need the elevation service to be "fixed", meaning have a good XML and be running for the workaround to actually start working.
  2. Add User Defined Script(s) to your user config:
    1. Post-Logoff, Executable Type:  c:\windows\system32\cmd.exe /c copy /y "C:\Program Files\ProfileUnity\Elevation\lwl_elevation_service.xml.bak" "C:\Program Files\ProfileUnity\Elevation\lwl_elevation_service.xml"
    2. If you're using ProfileDisk, then you'll also need this one:  Post-Logon, Executable Type:  c:\windows\system32\cmd.exe /c copy /y %userprofile%\userprofile.reg C:\Users\%USERNAME%\
  3. Have the user login – they WON’T have their profiledisk actually “in place” yet, but it will be mounted.  Have them logoff – this will fix the profiledisk for the next login.
  4. Then the on-going workaround is the copy of the elevation xml.bak on logoff.  So the file will continue to get broken for now, but on logoff it will be fixed by copying the bak.
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Article is closed for comments.